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KEY TO SYMBOLS 

 
Below are the symbols used in the manual to draw the reader's attention: 
 
 
 

Caution! Risk of electrocution. 
 
 
 

Caution! This operation must be performed by skilled workers. 
 
 
 

Read the following indications carefully. 
 
 
 

Further information. 
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INTRODUCTION 

 
The PROG DB software allows data of the following LCC instruments to be stored on Personal 
Computer: 
- W200; 
- WDOS; 
- WDESK; 
- WINOX; 
- WTAB; 
 
Transferring data from the instrument to the PC can take place in two ways: 

- Option OPZWUSB_: by USB key 
- Option OPZWDATIPC: by RS-232 serial port (or RS-485 via appropriate converter). 

 
The stored data (weighings carried out, batching data and alarms) can be consulted, printed out and 
used to carry out searches. 
 
Software functions: 
- Recognition of new instruments connected via serial communication; 
- Recognition of new instruments from backup files; 
- Customization of the known instruments, with name and notes. 
- Display of single instrument data; 
- Search among data of all the instruments (with the possibility to apply filters); 
- Export of displayed data and of the search procedures conducted in CSV; 
- Printing of displayed data and of the search procedures conducted; 
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INSTALLING AND CONFIGURING THE SOFTWARE 

 
To install the program follow the procedures stated below closely. 

 
 

Before handling the electrical connections of the system, ensure that the power supply is 
off. 

 
 

MINIMUM SYSTEM REQUIREMENTS 

 
Operating system: 
Microsoft Windows® XP/Vista/7 
 
Personal Computer 
- Intel Pentium 4 1.4 GHz or AMD Athlon XP 1500+ 
- 512 MB or more RAM 
- 50 MB Hard Drive free space 
 

It is necessary for the update "Microsoft NetFramework 3.5" to be installed (if not present 
you will be prompted to download it from the internet) 

 
 

INSTALLING THE SOFTWARE 

 
The supply includes a CD-ROM for installing PROG DB on PC. 
 
1. Insert the installation CD-ROM into the CD-ROM drive of the Computer; 
2. If the "automatic start" function is enabled wait for the program to start, otherwise double click 

the icon MY COMPUTER and then the CD-ROM drive icon, the CD contents will appear; 
3. Double click on the ProgDB_v1.3.8.exe icon (or 

latest version) to start the installation. You may 
need to perform this operation as an administrator: 
right click on the icon and select “Run as 
administrator”. 

4. Follow the video instructions to complete the 
program installation procedure; 

 
At the end of the procedure you can start the program 
from Windows start menu. 
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CONFIGURING THE SOFTWARE 

 
Start the program PROG DB from Windows start menu. 
 

In operating systems following Windows Vista it is necessary to run the application in 
administrator mode (see RUN AS AN ADMINISTRATOR section). 

 

In the main menu select Options to access the list of program settings. 
 
 

LANGUAGE SETTINGS 
 
By default the program is set to be displayed in ENGLISH. 
 

Access the menu Options -> Language to select the desired language from the drop-down 
menu. 

Press SAVE to confirm or CANCEL to cancel the changes. 
 
 

SERIAL COMMUNICATION SETTING 
 
The program allows the PC to be connected to an instrument via RS-232/RS-485 serial connection 
or to a network of instruments by RS-485 serial connection. 
 

To communicate with the instruments you need to select the serial communication port of 
the PC to be used and configure the relevant communication parameters with the same 
values set on the instruments. 

 

Access the menu Options -> Serial Port and set the values to be used from the drop-down 
menu. 
 
- Set a communication speed (baudrate) of 38400 or higher if you want to reduce the time required 
for transferring data from the instruments to the PC. 
 

- Set the protocol  (refer to the instrument manual for further information on serial 
communication setting). 
 
 

For further information refer to the CONNECTION BETWEEN PC AND SERIAL PORT 
section. 
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RUN AS AN ADMINISTRATOR 
 
To make permanent the execution as an administrator, it is necessary to: 
1. Open the program installation folder (by default the path is: 

C:\Program Files (x86)\LAUMAS\Prog_DB) 
2. Select the file Prog_DB.exe and right click 
 

 
 
3. Select Properties 
4. Open the tab “Compatibility” and check: “Run this program as an administrator” 
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DATA TRANSFER FROM INSTRUMENT TO PC 

 
Transferring data from the instrument to the PC into the program's working folder can take place in 
two ways: 

- Option OPZWUSB_: by USB key 
- Option OPZWDATIPC: by RS-232 serial port (or RS-485 via appropriate converter). 

 

Once the data is transferred, to be able to display them you need to import them into the database 
(see section IMPORTING DATA INTO THE DATABASE). 
 
 

DATA TRANSFER VIA SERIAL PORT (OPZWDATIPC) 

 
Before continuing, ensure that the PC is connected to the instrument correctly and that the 
instrument is turned on and in standby mode. 

 

Start the program PROG DB from Windows start menu and select the item File -> Connect from 
the program's main menu. 
 
Select the instrument you want 
to connect to (via the drop-down 
menu) or enter the modbus 
address in the appropriate field. 

Press the button CONNECT to 
start the connection to the 
instrument. 

 
 
The program tries to establish a connection with the instrument and the possible responses are as 
follows: 

- Response received: if the connection is established correctly; 
- No response: in this case check the connection and the parameters of the serial port both on 

the instrument and in the program. 
 

If it is a new instrument, the program recognises it and asks the user if he/she wishes to add 
it to the list of known instruments. 

 
At the end of the connection procedure, you can select: 

- WEIGHT: Display of weight present on the scale in real time; 

- DATA: Transfer of data memory from the instrument to the PC; 
 

Select the item DATA, press START and wait for the program to finish the data transfer. 
 

This operation may take up to several minutes depending on the baudrate set in the 
serial communication. 
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At the end of the data transfer, a message will appear stating that the data has been transferred. 
 

The data stored into the instrument have only been transferred to the program's working 
folder. In order to be able to display them you first need to import them into the database 
(see section IMPORTING DATA INTO THE DATABASE). 

 
 

DATA TRANSFER VIA USB KEY (OPZWUSB_) 

 
Refer to the instrument manual for information on the operation of the option 
OPZWUSB_ and the relevant configuration of the instrument. 

 
After transferring the data onto the USB key as described in the instrument manual, insert the USB 
key into the PC. 
 

Start the program PROG DB from Windows start menu and select the item File -> Import from 
the program's main menu. 
 

Press OPEN to select the 
source folder of the new files, 
select the 'removable drive' 
relating to the USB key from the 

relevant window and press OK. 
 
The program will transfer the 
files present on the USB key into 
the working folder of the 
program and will automatically 
appear in the list of available 
files.  

 
 
If you have an additional USB key where the data of other instruments are present, insert it into the 

PC and press OPEN again. 
 

The data stored into the instrument have only been transferred to the program's working 
folder. In order to be able to display them you first need to import them into the database 
(see section IMPORTING DATA INTO THE DATABASE). 
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IMPORTING DATA INTO THE DATABASE 

 
After transferring the batching data from the instrument to the working folder of PROG DB, as 
described in sections above, you can import the data into the database. 
 

Start the program PROG DB from Windows start menu and select the item File -> Import from 
the program's main menu. 
 
In the list of available files, all 
the files present inside the 
program's working folder are 
displayed. 
 

Press START to start the 
procedure of automatically 
importing the data into the 
database. 

 
 

The program processes one file at a time and its status goes from WAITING to IN PROGRESS 
until the import stage has been completed. Once the import is finished the file is marked as 

COMPLETED. 
Once all file present in the working folder have been imported you can display the LOG of the 

operation by pressing the button VIEW LOG. 
 
Close the import window and move onto displaying and searching for data. 
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DATA DISPLAY 

 
The software allows the data to be displayed via the following commands: 

1. View -> Instruments (display of data by instrument) 

2. View -> Search (display of batching data via searches) 

3. View -> Production (display of production data) 

4. View -> Consumption (display of consumption data) 
 
 

1) DISPLAY BY INSTRUMENT 

 

From the main menu select View -> Instruments. 
The list of known instruments appears and for each instrument the total number of batching cycles 
carried out is shown. 
 

File –> Print Preview: displays the list of instruments to print, press print icon to start the 
printing. 

Data –> Export CSV: exports the list of instruments in CSV format. 
 
After selecting the desired instrument you can: 

- Modify certain descriptive parameters of the instrument (e.g. add a name or notes); 
- Display the list of recorded weights (only available for BASE, REVERSE or weighbridge BGE 

model instruments); 
- Display the list of batching cycles (only available for LOAD, UNLOAD and 3/6/14 PRODUCTS 

instruments). 
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MODIFYING INSTRUMENT PARAMETERS 
 

Select the instrument you want to modify and press Modify: 

 
 
In the first section the factory data of the 
instrument and the name of the program set are 
shown. These data may not be modified. 
 
In the second section you can insert the name 
of the instrument and any notes, which will be 
displayed in the table and printed in the reports. 
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DISPLAYING THE LIST OF RECORDED WEIGHTS 
 
 

Display available only for BASE or REVERSE instruments. 
 
 
The date filter is automatically set on the current day. To disable it uncheck the “date” field. 

From the instrument display select View -> Details. 
The list of weights which the instrument has recorded and any alarms appears. 
 
At the top of the window it is possible to choose between different views of the data based on 
operation selected: 
 

- STANDARD: displays a list of weighed values and alarms (if present). 
 

 
 
In case of metric instrument, the fields related to the alibi ID will also be displayed. 
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- TOTALIZER: displays a list of weighed values and totals. 

 

 
 
 

- PIECE COUNTER: displays a list of weighed values with number of pieces and totals. 
 

 
 

In the right-hand side of the screen you can set the search filters. 
 

- WEIGHT: displays a list of weighed values; 

- ALARMS: displays a list of alarms ; 

- PEAK: displays PEAK value (if active); 

- COEFF: displays COEFF value (if active); 

- PROGR: displays the progressive weighed values (if active the registration of progressive 
weighed number) 

- DATE FILTER: enables the filter by date FROM/TO; 
 

File –> Print Preview: displays the list of data to print, press print icon to start the printing. 

Data –> Export CSV: exports the data in CSV format. 
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DISPLAYING THE LIST OF RECORDED WEIGHTS (WEIGHBRIDGE) 
 
 

Display available only for weighbridge instruments, BGE model. 
 
 
The program automatically enables the date filter on the current day. To disable it uncheck the 
“date” field. 

From the instrument display select View -> Details. 
The list of the weights recorded by the instrument appears. 
 

 
 
In the right-hand side of the screen it is possible to set the search filter related to the weight 
registration date. 

File -> Print Preview: displays the list of data to print, press the print icon to start printing. 

Data -> Export CSV: exports the data in CSV format. 
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DISPLAYING THE LIST OF BATCHING CYCLES 
 
 

Display available only for LOAD, UNLOAD and 3/6/14 PRODUCTS instruments. 
 
 
The date filter is automatically set on the current day. To disable it uncheck the “date” field. 
 

From the instrument display select View -> Details. 
The list of batching cycles which the instrument has recorded and any alarms appears (in standby 
mode). 
 

 
 
The total batched value for each cycle is shown in relation to the theoretical total value to be dosed 
and the descriptions of any alarms are shown together with the start and end date/time. 
 

File –> Print Preview: displays the list of data to print, press print icon to start the printing. 

Data –> Export CSV: exports the data in CSV format. 
 
 



 

 - 14 - 

DISPLAYING THE BATCHING CYCLE DETAIL 
 

Display available only for LOAD, UNLOAD and 3/6/14 PRODUCTS instruments. 
 
 
To display the detail of a single batching cycle, do as follows: 

- Select the batching cycle whose detail you want to display: 

- Select View -> Details from the main menu. 
 
The list of events which the instrument has recorded during the batching cycle appears: 
 

 
 

For each batched product the REAL WEIGHT is shown in relation to the THEORETICAL 
WEIGHT; the column WEIGHT ERROR contains the comparison between the two values. 
 

File –> Print Preview: displays the list of data to print, press print icon to start the printing. 

Data –> Export CSV: exports the data in CSV format. 
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2) BATCHING DATA SEARCH 

 

From the main menu select View -> Search. 
 

Press SEARCH to display the filters applicable to the searches: 
 

- INSTRUMENT: search solely for data of the selected instrument; 
- SCALE:     set the number of the desired scale; 

- FORMULA:  set the number of the desired formula; 

- PRODUCT:   set the number of the desired product; 

- DATE FROM:  set the start date and time for the search; 

- DATE TO:    set the end date and time for the search; 
 

Press APPLY to start the search for the desired data. 
 

 
 

At the bottom of the window the TOT REAL and the TOT THEORETICAL are shown. 
 

File –> Print Preview: displays the list of data to print, press print icon to start the printing. 

Data –> Export CSV: exports the data in CSV format. 
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3) PRODUCTION DISPLAY 

 

From the main menu select View -> Production. 
The software allows searches to be carried out on the data to calculate the quantity consumed for 
each formula (PRODUCTION). 
 

Press SEARCH to display the filters applicable to the searches: 
 

- INSTRUMENT:  Search solely for data of the selected instrument; 

- SCALE:     Set the number of the desired scale; 

- DATE FROM:  Set the start date and time for the search; 

- DATE TO:    Set the end date and time for the search; 
 

Press APPLY to start the search for the desired data. 
 

 
 
The list of production (theoretical and actual) is displayed broken down by: 
 

- SERIAL NUMBER (corresponds to the serial number of the instrument); 

- SCALE; 

- FORMULA; 
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4) CONSUMPYION DISPLAY 

 

From the main menu select View -> Consumption. 
The software allows searches to be carried out on the data to calculate the quantity consumed for 
each product (CONSUMPTION). 
 

Press SEARCH to display the filters applicable to the searches: 
 

- DEVICE:   Search solely for data of the selected instrument; 

- SCALE:    Set the number of the desired scale; 

- DATE FROM:  Set the start date and time for the search; 

- DATE TO:   Set the end date and time for the search; 
 

Press APPLY to start the search for the desired data. 
 

 
 
The list of consumption (theoretical and actual) is displayed broken down by: 
 

- SERIAL NUMBER (corresponds to the serial number of the instrument); 

- SCALE; 

- PRODUCT; 
 

File –> Print Preview: displays the list of data to print, press print icon to start the printing. 

Data –> Export CSV: exports the data in CSV format. 
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DATA PRINTOUT 

 

To set the printer to work with, from the main menu select File -> Printer Setup. 
 

To display the print preview, from the main menu select File -> Print Preview, then press print 
icon to start the printing. 
 

 
 

Press CLOSE to exit without printing. 
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APPENDICES 

 

CONNECTION BETWEEN PC AND SERIAL PORT 

 

RS232 SERIAL CONNECTION 
 

 
 

STRUMENTO GND TXD RXD 

W200 2 4 3 

WDOS 2 4 3 

WDESK 8 9 10 

WINOX 8 9 10 

 
 

CONNECTION TO RS485 VIA CONVLAU RS232 CONVERTER 

 
 

INSTRUMENT GND RS485 + RS485 - 

W200 2 18 17 

WDOS 2 18 17 

WDESK 8 6 5 

WINOX 8 6 5 
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If the RS485 network is longer than 100 metres or if baudrates higher than 9600 are 
used, two terminal resistors are required at the ends of the network. Connect two 120 
Ohm resistors between the + and '–' terminals of the line on the terminal strip of the 
instruments furthest away. Should there be different instruments or converters, refer 
to the specific manuals to determine whether it is necessary to connect the above-
mentioned resistors. 

 
 

CHECK CONNECTIONS 
 
After connecting the instrument to the PC, do as follows: 
 

1. Start the Prog DB software; 

2. Check the settings of the serial port on the instrument ( protocol); 

3. Check that the settings of the serial port of the PC (Options -> Serial Port) are correct 
(same values as: Baudrate, Parity, StopBit); 

4. Start the instrument connection (File -> Connect) by selecting the desired instrument from 
the drop-down menu or by entering the corresponding Modbus address); 

5. Press CONNECT and wait for the response from the program; 
 
If the connection is unsuccessful, you are advised to repeat the procedure using a lower BaudRate. 
 
 

MS EXCEL DATA EXPORT 

 
Open the screen to be exported and do one of the following: 
 
Standard method (also import columns headings): 

Using filters select the data to be exported and in the toolbar press: Data –> Export CSV. 
Open MS Excel and select: Data –> Import external data -> Import data. 
Browse folders to find and select the exported file, follow the on-screen instructions to complete the 
import. 
 
Quick method (import values only): 
Select rows to be exported and press CTRL+C (copy), open Excel and select cell A1, press 
CTRL+V (paste). 
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